Back to overview
Monitoring Payment Link Issue
Jul 31 at 10:04am CDT
Affected services
Payva Portal
Resolved
Jul 31 at 10:04am CDT
All payment links are now fully operational. Our team continues to investigate the root cause and will keep you informed of any developments. We sincerely apologize for the service disruption and appreciate your patience while we worked to resolve the issue.
Affected services